const regex = /\n+^(I )?hope (it|this|that) helps?(\s|:-?\)|[!.])*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n+^(I )?hope (it|this|that) helps?(\\s|:-?\\)|[!.])*$', 'gmi')
const str = `Just make a simple casting type:
\`\`\`
x[0] = [x[0]]
x[0].append(...)
\`\`\`
This will work as your expectation.
Hope this helps..`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);