# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\n+^(I )?hope (it|this|that) helps?(\s|:-?\)|[!.])*$"
test_str = ("Just make a simple casting type:\n"
"```\n"
"x[0] = [x[0]]\n"
"x[0].append(...)\n\n"
"```\n"
"This will work as your expectation.\n\n"
"Hope this helps..")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.