# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/(?:(?!v[1-4])[a-zA-Z]*[\d_-]+[a-zA-Z]*|[0-9]+)/\/x/gm;t' <<< "/v1/profile/abc13abc/13abc/cDe12/abc-bla/text_tw/HELLO/test/random/2234"