$re = '//(?:(?!v[1-4])[a-zA-Z]*[\d_-]+[a-zA-Z]*|[0-9]+)/m';
$str = '/v1/profile/abc13abc/13abc/cDe12/abc-bla/text_tw/HELLO/test/random/2234';
$subst = "/x";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;