use strict;
my $str = '/v1/profile/abc13abc/13abc/cDe12/abc-bla/text_tw/HELLO/test/random/2234';
my $regex = qr//(?:(?!v[1-4])[a-zA-Z]*[\d_-]+[a-zA-Z]*|[0-9]+)/mp;
my $subst = '/x';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";