import Foundation
let pattern = #"/(?:(?!v[1-4])[a-zA-Z]*[\d_-]+[a-zA-Z]*|[0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"/v1/profile/abc13abc/13abc/cDe12/abc-bla/text_tw/HELLO/test/random/2234"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/x"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)