# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"/(?:(?!v[1-4])[a-zA-Z]*[\d_-]+[a-zA-Z]*|[0-9]+)"
test_str = "/v1/profile/abc13abc/13abc/cDe12/abc-bla/text_tw/HELLO/test/random/2234"
subst = "/x"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.