#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a[^>]*>[^<]*</a>(*SKIP)(*FAIL)|https?:\S+"
Local $sString = " https://vimeo.com/id1 //this line should get replaced with embed code by module" & @CRLF & _
"" & @CRLF & _
" <a href="https://vimeo.com/id1"> Check out this video </a> //here, anything that is in href="" should not be replaced" & @CRLF & _
"on <a href="https://vimeo.com"> Vimeo </a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")