// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<a[^>]*>[^<]*</a>(*SKIP)(*FAIL)|https?:\S+").unwrap();
let string = " https://vimeo.com/id1 //this line should get replaced with embed code by module
<a href=\"https://vimeo.com/id1\"> Check out this video </a> //here, anything that is in href=\"\" should not be replaced
on <a href=\"https://vimeo.com\"> Vimeo </a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}