re = /<a[^>]*>[^<]*<\/a>(*SKIP)(*FAIL)|https?:\S+/m
str = ' https://vimeo.com/id1 //this line should get replaced with embed code by module
<a href="https://vimeo.com/id1"> Check out this video </a> //here, anything that is in href="" should not be replaced
on <a href="https://vimeo.com"> Vimeo </a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end