import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a[^>]*>[^<]*</a>(*SKIP)(*FAIL)|https?:\\S+";
final String string = " https://vimeo.com/id1 //this line should get replaced with embed code by module\n\n"
+ " <a href=\"https://vimeo.com/id1\"> Check out this video </a> //here, anything that is in href=\"\" should not be replaced\n"
+ "on <a href=\"https://vimeo.com\"> Vimeo </a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}