using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^>]*>[^<]*</a>(*SKIP)(*FAIL)|https?:\S+";
string input = @" https://vimeo.com/id1 //this line should get replaced with embed code by module
<a href=""https://vimeo.com/id1""> Check out this video </a> //here, anything that is in href="" should not be replaced
on <a href=""https://vimeo.com""> Vimeo </a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}