package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([a-z0-9 >}/])
\s* ({(var):([a-z0-9_/.-]+)([?0-9]+)?}) \s*
([a-z0-9 {</])`)
var str = ` <article class="ibvt">
<p>
{var:contactText}
</p>
</article>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}