import Foundation
let pattern = #"""
([a-z0-9 >}/])
\s* ({(var):([a-z0-9_/.-]+)([?0-9]+)?}) \s*
([a-z0-9 {</])
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
<article class="ibvt">
<p>
{var:contactText}
</p>
</article>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}