import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z0-9 >\\}/])\n"
+ "\\s* (\\{(var):([a-z0-9_/.-]+)([?0-9]+)?\\}) \\s*\n"
+ "([a-z0-9 \\{</])";
final String string = " <article class=\"ibvt\">\n"
+ " <p>\n"
+ " {var:contactText}\n"
+ " </p>\n"
+ " </article>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}