#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{0,2}—\d{0,2}\s[а-я]+\n|\d{0,2}\s[а-я]+\s—\s\d{0,2}\s[а-я]+\n"
Local $sString = "26 апреля — 2 мая" & @CRLF & _
"26 апреля — 2 мая" & @CRLF & _
"31 мая — 6 июня" & @CRLF & _
"26 апреля — 2 мая" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")