import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{0,2}—\\d{0,2}\\s[а-я]+\\n|\\d{0,2}\\s[а-я]+\\s—\\s\\d{0,2}\\s[а-я]+\\n";
final String string = "26 апреля — 2 мая\n"
+ "26 апреля — 2 мая\n"
+ "31 мая — 6 июня\n"
+ "26 апреля — 2 мая\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}