re = /\d{0,2}—\d{0,2}\s[а-я]+\n|\d{0,2}\s[а-я]+\s—\s\d{0,2}\s[а-я]+\n/m
str = '26 апреля — 2 мая
26 апреля — 2 мая
31 мая — 6 июня
26 апреля — 2 мая
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end