import Foundation
let pattern = #"\d{0,2}—\d{0,2}\s[а-я]+\n|\d{0,2}\s[а-я]+\s—\s\d{0,2}\s[а-я]+\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
26 апреля — 2 мая
26 апреля — 2 мая
31 мая — 6 июня
26 апреля — 2 мая
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)