package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{0,2}—\d{0,2}\s[а-я]+\n|\d{0,2}\s[а-я]+\s—\s\d{0,2}\s[а-я]+\n`)
var str = `26 апреля — 2 мая
26 апреля — 2 мая
31 мая — 6 июня
26 апреля — 2 мая
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}