use strict;
my $str = 'nttttouterttt
ntptttouterttt';
my $regex = qr/n[t]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";