using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(b|t)[ea]r";
string input = @"abc, easy as 123
abcdef, easy as 123456!!
When it is breezy, I wear my green fleece!
That Cat wearing the Fat Hat is about 123 years old!
Python in morse code is .--. -.-- - .... --- -.
Like watching bluebirds, blackbirds, and redbirds!
THE PRANCING PONY is located in Bree.
Today is October, 2, 2020. We started class at 8:00a.
Random: ljsd98s9fhekSDKF7seiwe7
In a hole in the ground there lived a hobbit. Not a nasty, dirty, wet hole, filled with the ends of worms and an oozy smell, nor yet a dry, bare, sandy hole with nothing in it to sit down on or to eat: it was a hobbit-hole, and that means comfort.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}