re = /(b|t)[ea]r/m
str = 'abc, easy as 123
abcdef, easy as 123456!!
When it is breezy, I wear my green fleece!
That Cat wearing the Fat Hat is about 123 years old!
Python in morse code is .--. -.-- - .... --- -.
Like watching bluebirds, blackbirds, and redbirds!
THE PRANCING PONY is located in Bree.
Today is October, 2, 2020. We started class at 8:00a.
Random: ljsd98s9fhekSDKF7seiwe7
In a hole in the ground there lived a hobbit. Not a nasty, dirty, wet hole, filled with the ends of worms and an oozy smell, nor yet a dry, bare, sandy hole with nothing in it to sit down on or to eat: it was a hobbit-hole, and that means comfort.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end