// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(b|t)[ea]r").unwrap();
let string = "abc, easy as 123
abcdef, easy as 123456!!
When it is breezy, I wear my green fleece!
That Cat wearing the Fat Hat is about 123 years old!
Python in morse code is .--. -.-- - .... --- -.
Like watching bluebirds, blackbirds, and redbirds!
THE PRANCING PONY is located in Bree.
Today is October, 2, 2020. We started class at 8:00a.
Random: ljsd98s9fhekSDKF7seiwe7
In a hole in the ground there lived a hobbit. Not a nasty, dirty, wet hole, filled with the ends of worms and an oozy smell, nor yet a dry, bare, sandy hole with nothing in it to sit down on or to eat: it was a hobbit-hole, and that means comfort.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}