import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(b|t)[ea]r";
final String string = "abc, easy as 123\n"
+ "abcdef, easy as 123456!!\n"
+ "When it is breezy, I wear my green fleece!\n"
+ "That Cat wearing the Fat Hat is about 123 years old!\n"
+ "Python in morse code is .--. -.-- - .... --- -.\n"
+ "Like watching bluebirds, blackbirds, and redbirds!\n"
+ "THE PRANCING PONY is located in Bree.\n"
+ "Today is October, 2, 2020. We started class at 8:00a.\n"
+ "Random: ljsd98s9fhekSDKF7seiwe7\n\n"
+ "In a hole in the ground there lived a hobbit. Not a nasty, dirty, wet hole, filled with the ends of worms and an oozy smell, nor yet a dry, bare, sandy hole with nothing in it to sit down on or to eat: it was a hobbit-hole, and that means comfort.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}