# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(b|t)[ea]r"
test_str = ("abc, easy as 123\n"
"abcdef, easy as 123456!!\n"
"When it is breezy, I wear my green fleece!\n"
"That Cat wearing the Fat Hat is about 123 years old!\n"
"Python in morse code is .--. -.-- - .... --- -.\n"
"Like watching bluebirds, blackbirds, and redbirds!\n"
"THE PRANCING PONY is located in Bree.\n"
"Today is October, 2, 2020. We started class at 8:00a.\n"
"Random: ljsd98s9fhekSDKF7seiwe7\n\n"
"In a hole in the ground there lived a hobbit. Not a nasty, dirty, wet hole, filled with the ends of worms and an oozy smell, nor yet a dry, bare, sandy hole with nothing in it to sit down on or to eat: it was a hobbit-hole, and that means comfort.\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.