#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Match[\s\S]*?(?=^$|\Z)"
Local $sString = "Match User thedomain\user1" & @CRLF & _
" ChrootDirectory E:\sftp\heatism\user1" & @CRLF & _
" PermitTunnel no" & @CRLF & _
" AllowAgentForwarding no" & @CRLF & _
" AllowTcpForwarding no" & @CRLF & _
" X11Forwarding no" & @CRLF & _
" ForceCommand internal-sftp" & @CRLF & _
"" & @CRLF & _
"Match User thedomain\user2" & @CRLF & _
" ChrootDirectory E:\sftp\heatism\user2" & @CRLF & _
" PermitTunnel no" & @CRLF & _
" AllowAgentForwarding no" & @CRLF & _
" AllowTcpForwarding no" & @CRLF & _
" X11Forwarding no" & @CRLF & _
" ForceCommand internal-sftp" & @CRLF & _
"" & @CRLF & _
"Match User thedomain\user3" & @CRLF & _
" ChrootDirectory E:\sftp\heatism\user3" & @CRLF & _
" PermitTunnel no" & @CRLF & _
" AllowAgentForwarding no" & @CRLF & _
" AllowTcpForwarding no" & @CRLF & _
" X11Forwarding no" & @CRLF & _
" ForceCommand internal-sftp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")