const regex = /^Match[\s\S]*?(?=^$|\Z)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Match[\\s\\S]*?(?=^$|\\Z)', 'gm')
const str = `Match User thedomain\\user1
ChrootDirectory E:\\sftp\\heatism\\user1
PermitTunnel no
AllowAgentForwarding no
AllowTcpForwarding no
X11Forwarding no
ForceCommand internal-sftp
Match User thedomain\\user2
ChrootDirectory E:\\sftp\\heatism\\user2
PermitTunnel no
AllowAgentForwarding no
AllowTcpForwarding no
X11Forwarding no
ForceCommand internal-sftp
Match User thedomain\\user3
ChrootDirectory E:\\sftp\\heatism\\user3
PermitTunnel no
AllowAgentForwarding no
AllowTcpForwarding no
X11Forwarding no
ForceCommand internal-sftp`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}