$re = '/^Match[\s\S]*?(?=^$|\Z)/m';
$str = 'Match User thedomain\\user1
ChrootDirectory E:\\sftp\\heatism\\user1
PermitTunnel no
AllowAgentForwarding no
AllowTcpForwarding no
X11Forwarding no
ForceCommand internal-sftp
Match User thedomain\\user2
ChrootDirectory E:\\sftp\\heatism\\user2
PermitTunnel no
AllowAgentForwarding no
AllowTcpForwarding no
X11Forwarding no
ForceCommand internal-sftp
Match User thedomain\\user3
ChrootDirectory E:\\sftp\\heatism\\user3
PermitTunnel no
AllowAgentForwarding no
AllowTcpForwarding no
X11Forwarding no
ForceCommand internal-sftp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);