import re
regex = re.compile(r"^Match[\s\S]*?(?=^$|\Z)", flags=re.MULTILINE)
test_str = ("Match User thedomain\\user1\n"
" ChrootDirectory E:\\sftp\\heatism\\user1\n"
" PermitTunnel no\n"
" AllowAgentForwarding no\n"
" AllowTcpForwarding no\n"
" X11Forwarding no\n"
" ForceCommand internal-sftp\n\n"
"Match User thedomain\\user2\n"
" ChrootDirectory E:\\sftp\\heatism\\user2\n"
" PermitTunnel no\n"
" AllowAgentForwarding no\n"
" AllowTcpForwarding no\n"
" X11Forwarding no\n"
" ForceCommand internal-sftp\n\n"
"Match User thedomain\\user3\n"
" ChrootDirectory E:\\sftp\\heatism\\user3\n"
" PermitTunnel no\n"
" AllowAgentForwarding no\n"
" AllowTcpForwarding no\n"
" X11Forwarding no\n"
" ForceCommand internal-sftp")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")