using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#[\w\d][\w\-]*";
string input = @"#hashtag some text #hash; #123
and # not because markdown
# that not
#33 that is not
either but #3isok
or #isok3
astring#andthatshouldnotmatch
#hashtagalone
\n#hashatthebeginning
hello #hashattheend\n
#has_htag
#ano-the-rone";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}