re = /#[\w\d][\w\-]*/m
str = '#hashtag some text #hash; #123
and # not because markdown
# that not
#33 that is not
either but #3isok
or #isok3
astring#andthatshouldnotmatch
#hashtagalone
\\n#hashatthebeginning
hello #hashattheend\\n
#has_htag
#ano-the-rone'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end