use strict;
my $str = '#hashtag some text #hash; #123
and # not because markdown
# that not
#33 that is not
either but #3isok
or #isok3
astring#andthatshouldnotmatch
#hashtagalone
\\n#hashatthebeginning
hello #hashattheend\\n
#has_htag
#ano-the-rone';
my $regex = qr/#[\w\d][\w\-]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}