import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#[\\w\\d][\\w\\-]*";
final String string = "#hashtag some text #hash; #123\n"
+ " and # not because markdown\n"
+ "# that not\n"
+ "#33 that is not \n"
+ "either but #3isok \n"
+ " or #isok3\n"
+ "astring#andthatshouldnotmatch \n"
+ " #hashtagalone\n"
+ " \\n#hashatthebeginning\n"
+ "hello #hashattheend\\n\n"
+ "#has_htag \n"
+ "#ano-the-rone";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}