#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https):\/\/paypal\.me\/.+"
Local $sString = "http://www.paypal.com" & @CRLF & _
"https://paypal.me/sendmerimoneynow?locale.x=en_GB" & @CRLF & _
"https://paypal.me/s/fjldj" & @CRLF & _
"http://paypal.me/fldjfskj" & @CRLF & _
"https://www.paypal.com/us/smarthelp/article/what-is-paypal.me-faq3025"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")