import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https):\\/\\/paypal\\.me\\/.+";
final String string = "http://www.paypal.com\n"
+ "https://paypal.me/sendmerimoneynow?locale.x=en_GB\n"
+ "https://paypal.me/s/fjldj\n"
+ "http://paypal.me/fldjfskj\n"
+ "https://www.paypal.com/us/smarthelp/article/what-is-paypal.me-faq3025";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}