re = /^(?:https):\/\/paypal\.me\/.+/m
str = 'http://www.paypal.com
https://paypal.me/sendmerimoneynow?locale.x=en_GB
https://paypal.me/s/fjldj
http://paypal.me/fldjfskj
https://www.paypal.com/us/smarthelp/article/what-is-paypal.me-faq3025'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end