using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https):\/\/paypal\.me\/.+";
string input = @"http://www.paypal.com
https://paypal.me/sendmerimoneynow?locale.x=en_GB
https://paypal.me/s/fjldj
http://paypal.me/fldjfskj
https://www.paypal.com/us/smarthelp/article/what-is-paypal.me-faq3025";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}