const regex = /^(?:https):\/\/paypal\.me\/.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https):\\\/\\\/paypal\\.me\\\/.+', 'gm')
const str = `http://www.paypal.com
https://paypal.me/sendmerimoneynow?locale.x=en_GB
https://paypal.me/s/fjldj
http://paypal.me/fldjfskj
https://www.paypal.com/us/smarthelp/article/what-is-paypal.me-faq3025`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}