using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)}";
string input = @"{'ability': 5075, 'level': 1, 'time': 249},
{'ability': 5076, 'level': 2, 'time': 378},
{'ability': 5075, 'level': 3, 'time': 448},
{'ability': 5076, 'level': 4, 'time': 595},
{'ability': 5075, 'level': 5, 'time': 744},
{'ability': 5077, 'level': 6, 'time': 959},
{'ability': 5074, 'level': 7, 'time': 1086},
{'ability': 5075, 'level': 8, 'time': 1384},
{'ability': 5076, 'level': 9, 'time': 1386}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}