// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)}").unwrap();
let string = "{'ability': 5075, 'level': 1, 'time': 249},
{'ability': 5076, 'level': 2, 'time': 378},
{'ability': 5075, 'level': 3, 'time': 448},
{'ability': 5076, 'level': 4, 'time': 595},
{'ability': 5075, 'level': 5, 'time': 744},
{'ability': 5077, 'level': 6, 'time': 959},
{'ability': 5074, 'level': 7, 'time': 1086},
{'ability': 5075, 'level': 8, 'time': 1384},
{'ability': 5076, 'level': 9, 'time': 1386}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}