# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+)}"
test_str = ("{'ability': 5075, 'level': 1, 'time': 249},\n"
" {'ability': 5076, 'level': 2, 'time': 378},\n"
" {'ability': 5075, 'level': 3, 'time': 448},\n"
" {'ability': 5076, 'level': 4, 'time': 595},\n"
" {'ability': 5075, 'level': 5, 'time': 744},\n"
" {'ability': 5077, 'level': 6, 'time': 959},\n"
" {'ability': 5074, 'level': 7, 'time': 1086},\n"
" {'ability': 5075, 'level': 8, 'time': 1384},\n"
" {'ability': 5076, 'level': 9, 'time': 1386}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.