const regex = new RegExp('(\\d+)}', 'gm')
const str = `{'ability': 5075, 'level': 1, 'time': 249},
{'ability': 5076, 'level': 2, 'time': 378},
{'ability': 5075, 'level': 3, 'time': 448},
{'ability': 5076, 'level': 4, 'time': 595},
{'ability': 5075, 'level': 5, 'time': 744},
{'ability': 5077, 'level': 6, 'time': 959},
{'ability': 5074, 'level': 7, 'time': 1086},
{'ability': 5075, 'level': 8, 'time': 1384},
{'ability': 5076, 'level': 9, 'time': 1386}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}