import Foundation
let pattern = #"(\d+)}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{'ability': 5075, 'level': 1, 'time': 249},
{'ability': 5076, 'level': 2, 'time': 378},
{'ability': 5075, 'level': 3, 'time': 448},
{'ability': 5076, 'level': 4, 'time': 595},
{'ability': 5075, 'level': 5, 'time': 744},
{'ability': 5077, 'level': 6, 'time': 959},
{'ability': 5074, 'level': 7, 'time': 1086},
{'ability': 5075, 'level': 8, 'time': 1384},
{'ability': 5076, 'level': 9, 'time': 1386}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)