#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)(?s:\A.*?^BAR)(*SKIP)(*F)|^data-key.*?,"
Local $sString = "data-key=foo1," & @CRLF & _
"data-key=foo2," & @CRLF & _
"data-key=foo3," & @CRLF & _
"BAR," & @CRLF & _
"data-key=foo4," & @CRLF & _
"asd" & @CRLF & _
"data-key=foo5," & @CRLF & _
"asfda" & @CRLF & _
"data-key=foo6, foo bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")