re = /(?m)(?s:\A.*?^BAR)(*SKIP)(*F)|^data-key.*?,/m
str = 'data-key=foo1,
data-key=foo2,
data-key=foo3,
BAR,
data-key=foo4,
asd
data-key=foo5,
asfda
data-key=foo6, foo bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end