import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?s:\\A.*?^BAR)(*SKIP)(*F)|^data-key.*?,";
final String string = "data-key=foo1,\n"
+ "data-key=foo2,\n"
+ "data-key=foo3,\n"
+ "BAR,\n"
+ "data-key=foo4,\n"
+ "asd\n"
+ "data-key=foo5,\n"
+ "asfda\n"
+ "data-key=foo6, foo bar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}