const regex = /(?m)(?s:\A.*?^BAR)(*SKIP)(*F)|^data-key.*?,/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)(?s:\\A.*?^BAR)(*SKIP)(*F)|^data-key.*?,', 'gm')
const str = `data-key=foo1,
data-key=foo2,
data-key=foo3,
BAR,
data-key=foo4,
asd
data-key=foo5,
asfda
data-key=foo6, foo bar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}