$re = '/(?m)(?s:\A.*?^BAR)(*SKIP)(*F)|^data-key.*?,/m';
$str = 'data-key=foo1,
data-key=foo2,
data-key=foo3,
BAR,
data-key=foo4,
asd
data-key=foo5,
asfda
data-key=foo6, foo bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);