using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"PosService\s+AddInfo:(?<info_code>.+)";
string input = @"[Information] PosService AddInfo:[5006] - Stop customer";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}